Access to Management application currently unavailable
Incident Report for LaunchNotes
Resolved
This incident has been resolved, thank you for your patience!
Posted Aug 30, 2021 - 17:45 PDT
Investigating
We are currently investigating this issue.
Posted Aug 30, 2021 - 15:42 PDT
This incident affected: Management App, Embed applications, and API.