We're are currently investigating an outage across our management portal and public pages
Incident Report for LaunchNotes
Resolved
This incident has been resolved.
Posted Apr 16, 2020 - 10:09 PDT
Monitoring
We have resolved the issue and are monitoring the situation.
Posted Apr 16, 2020 - 08:18 PDT
Investigating
We are currently investigating this issue.
Posted Apr 16, 2020 - 08:16 PDT
This incident affected: Notifications, Management App, and API.