Email notifications are delayed
Incident Report for LaunchNotes
Resolved
We have identified the cause of the delayed notifications and resolved the issue. Thank you for your patience!
Posted Oct 30, 2020 - 18:06 PDT
Investigating
We are currently investigating an email processing issue. Emails are being queued and will be sent as soon as this issue is resolved.
Posted Oct 30, 2020 - 16:00 PDT
This incident affected: Notifications.